Browser compatibility: not with IE

Posted by

Early reports (thank you, Wim and Sven) suggest The Dark Sign works with recent versions of Chrome (tested in Windows), UC Browser (tested in Windows), Firefox (tested in Windows), Edge (tested in Windows), Opera (tested in Windows and macOS) and Safari (tested in macOS and iOS).

The game does NOT work with any version of Internet Explorer.

Leave a Reply

Your email address will not be published. Required fields are marked *

Notify me of followup comments via e-mail. You can also subscribe without commenting.